Quand Kaspersky ramène votre PC en 1998

Écrit par fdgeek
8 minutes
Quand Kaspersky ramène votre PC en 1998

En informatique, il y a trois types de galères : la petite galère courante facilement réparable, la grosse galère ( panne majeure, logicielle ou matérielle vite identifiée) et, la galère "sans nom".😄

C'est ce type de galère indéfinissable à laquelle j'ai été confronté depuis mercredi dernier.

Comme tous les jours, je démarre mon PC et là, dès le démarrage de Windows 7 je trouve le lancement particulièrement long (message "Veuillez patienter...") et l'ouverture de session interminable (message "Bienvenue...). Pas de son au démarrage et quand  la session s'ouvre enfin, aucun son non plus et je me retrouve avec une barre des tâches revenue au style classique de Windows 98 avec une belle notification d'erreur : "Windows n'a pas pu se connecter au Service de notification d'évènements système...blablabla etc).

Sachant qu'un bug dans de précédentes mises à jour de Windows avait déjà causé une erreur similaire il y a quelques mois je procède illico presto à la commande qui remédie au problème : une remise à zéro du catalogue Winsock comme préconisé.

J'ouvre donc une ligne de commande en administrateur et j'exécute la commande :

netsh winsock reset catalog

Je reboot le PC mais, au redémarrage, idem, même problème. Je jette un coup d'œil dans le gestionnaire d'évènements et je constate que toute une flopée de services sont en échec, gelés ou en attente de démarrage (notamment les services audio, thèmes, gestionnaire de classes multimédias, etc...). Ceci explique sans nul doute le retour au style classique. Je relance manuellement ces services et hop, problème résolu, le son et les thèmes AeroPeek sont de retour. Dans le doute, je ferme la session, je la ré-ouvre et, tout semble de nouveau parfaitement fonctionner

Mais je me réjouis trop vite. Si je redémarre Windows, cela recommence. Je prends donc le temps de laisser le PC démarrer  (longuement...) et, en attendant que tous les services Windows puissent se charger, j'opte pour mon PC portable.

Mais là, grosse mauvaise surprise, même lenteur et même erreur au démarrage sur le portable. Dans le doute, j'allume le troisième PC familial et, même punition. Mes machines ont été maraboutées... 😂 Grrrr !🤬

Le problème se produisant sur les 3 machines, j'élimine immédiatement une cause matérielle et n'ayant rien installé récemment sauf le dernier patch cumulatif de Microsoft pour Wndows 7, je tente sa désinstallation sur une des machines. Ceci fait, rien de change. Je contrôle donc le disque et l'intégrité des fichiers système :

chkdsk /F /R
scf /scannow

Mais là aussi RAS, idem. Grrrr !🤬

Je pense alors la possibilité d'une infection virale. Sur le même PC, je boote sur la distribution Linux installée en double amorçage et tout fonctionne nickel (le souci concerne donc uniquement Windows). Je scanne les répertoires sensibles de la partition Windows avec ClamAv mais rien. Pour être sûr du PC, je démarre sur un CD de récupération Kaspersky Antivirus et je lance un scan complet de la partition Windows mais aucun programme malveillant à l'horizon. re Grrr !😡

Je relance Windows et, après plusieurs minutes d'un démarrage digne d'un PC 386 des années 90, je passe un coup de AdwCleraner, mais, toujours rien.

Je relance à nouveau les services patraques et je mets à jour les pilotes vidéo, son et réseau. On ne sait jamais et, comme les trois machines on une configuration matérielle bien différente, je n'y crois pas trop. Pour le coup j'ai raison, rien n'est résolu.

J'en viens alors à soupçonner Microsoft de volontairement pénaliser les derniers irréductibles de Windows 7 pour les forcer à migrer vers Windows 10. (Méa Culpa 🙄) J'essaye de rester zen...

Je réfléchi à nouveau à ce qui aurait pu changer sur ces trois machines avant ce mercredi 4 mars 2020 et je ne vois qu'une seule chose :  Kaspersky Antivirus 2020 s'est mis automatiquement à jour comme d'habitude.

Je tente alors le coup en désinstallant l'antivirus sur une des machines. Je relance et tout est OK. (Ouf ! enfin un potentiel coupable 😉). Je réinstalle KAV 2020, les bases se mettent à jour et je relance le PC...

Là, miracle, aucune lenteur, aucune erreur et aucun service système en carafe. Je fais passer la souris sur l'icône de l'antivirus en barre des tâches et cela m'indique une version 20.0.14.1085(h). Je regarde sur les deux autres machines et je vois que l'icône indique une version plus récente ( 20.0.14.1085(i)).

Ce serait donc ce patch (i) dont l'installation date de la même semaine qui serait en cause.

Pour confirmer cela, le relance manuellement une mise à jour de l'antivirus sur la machine possédant le patch (h), je vois qu'elle pèse plus lourd qu"un update habituel ce qui traduit généralement le téléchargement d'un patch correctif. Je relance le PC et là, sans surprise, lenteur, plus de son, services et thème Aero en carafe, etc.. Je regarde la version de l'antivirus: le patch (i) est installé.

C'est donc à cette dernière version que je dois la cause de tous mes déboires.

Je me replonge alors dans le gestionnaire d'évènements Windows et je scrute tout ce qui concerne Kaspersky Antivirus. Et, dans la section sécurité, je trouve un avertissement au sujet d'un fichier .dll dont le contrôle de hachage est invalide : klhkum.dll

C'est donc le contrôle de la signature ou de l'intégrité de ce fichier qui provoque tous ces problèmes sous Windows 7. Pour en avoir confirmation, je fais un tour sur les forums dédiés de Kaspersky et je finis par dénicher un topic qui parle de ce même problème en question. Apparemment, le support technique est sur le coup et j'espère qu'un patch qui corrige cela  sera disponible rapidement.

En attendant, une solution de contournement est possible en désactivant l'autodéfense de Kaspersky Antivirus le temps de renommer temporairement ce fichier (changer l'extension en .old ou .dll0 ) et qui ne semble pas perturber le fonctionnement de l'application.

C:\Program Files (x86)\Common Files\Kaspersky Lab\klhk\klhk_x64\klhkum.dll0

Attention tout de même, soyez prudent, car si tout semble fonctionner normalement, rien ne garantit que l'efficacité de l'antivirus n'en soit pas amoindrie.

J'ai moi même fait remonter ce problème au support technique de Kaspersky et j'espère que comme d'habitude ils seront réactifs, car il y encore pas mal de monde sous Windows 7.

Voilà donc ce que je qualifie de : galère informatique sans nom et qui ma bien pris la tête durant 5 jours. 😆

J'espère au moins que si d'autres utilisateurs sont confrontés au même problème ils liront ce post assez rapidement car je pense qu'il leur évitera de nombreuses heures de manipulations au final bien inutiles....